MedWise Performance Issues

Incident Report for AnewHealth External

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 09:52 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 14, 2025 - 09:29 EDT

Identified

We are aware of an issue that is currently affecting MedWise. Our team is diligently working to resolve this as quickly as possible. We apologize for any inconvenience this is causing and will provide an update as soon as we know more information on a timeline for resolution.

For other or urgent concerns, please contact your dedicated liaison.
Posted Oct 14, 2025 - 09:25 EDT
This incident affected: MCS - MedWise Clinical Solutions and MCP - MedWise Clinical Platform.