The testing and check out activities are completed, and full functionality has been restored. We will continue to closely monitor service.
Posted Jul 24, 2025 - 14:52 EDT
Update
The issue has been identified. A change was made, and checkout results are positive. The teams are still testing results at this time.
Posted Jul 24, 2025 - 14:40 EDT
Update
The technicians are diligently working on the cause for this issue. We will continue providing updates as new information is available.
Posted Jul 24, 2025 - 13:56 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 24, 2025 - 11:56 EDT
Update
The system restart did not correct the issue. The technical team continues to triage.
Posted Jul 24, 2025 - 11:14 EDT
Update
The technical team is currently performing a system restart.
Posted Jul 24, 2025 - 10:39 EDT
Identified
We are aware of an issue that is currently affecting MedWise. Our team is diligently working to resolve this as quickly as possible. We apologize for any inconvenience this is causing and will provide an update as soon as we know more information.
For other or urgent concerns, please contact your dedicated liaison.
Posted Jul 24, 2025 - 10:16 EDT
This incident affected: MCS - MedWise Clinical Solutions.