Monitoring - AWS has updated their service health dashboard stating the issue is now resolved. We will continue to closely monitor our services throughout the morning. A final communication will be sent, once all of our systems have been verified.
Posted Oct 20, 2025 - 21:06 EDT
Update
AWS is making progress in restoring service, but please be aware that until they confirm all services are fully restored, you may still experience intermittent performance issues throughout the evening. We will continue to monitor their status activity and provide updates as new information is received.
Posted Oct 20, 2025 - 17:21 EDT
Update
Teams are seeing some application processing improvements, but services still remain unstable at this time.
Posted Oct 20, 2025 - 16:09 EDT
Update
AWS continues to monitor the results of their mitigation efforts and are seeing positive results. We will continue providing updates as they are received.
Posted Oct 20, 2025 - 14:44 EDT
Monitoring
There is currently an outage with our AWS cloud provider. All applications hosted in AWS that includes but is not limited to.
-EireneRx -EOM -EireneRx Reporting -Medwise
We are actively monitoring the situation and are in touch with AWS account team who are providing updates when new statuses are received.
Posted Oct 20, 2025 - 14:06 EDT
This incident affected: MCS - MedWise Clinical Solutions and MCP - MedWise Clinical Platform.