MedWise®: User Login Issues

Incident Report for AnewHealth External

Resolved

As of 3:35pm EDT, MedWise is operational. We apologize for the inconvenience you may have experienced and appreciate your patience as we investigated and resolved the outage. Should you have accessibility issues or questions, please contact your dedicated liaison.
Posted Apr 20, 2021 - 15:53 EDT

Identified

We are aware of an issue that is currently affecting users' ability to login to MedWise®. Our team is diligently working to resolve this as quickly as possible. We apologize for any inconvenience this is causing and will provide an update as soon as we know more.

For other or urgent concerns, please contact your dedicated liaison.
Posted Apr 20, 2021 - 15:09 EDT
This incident affected: MCS - MedWise Clinical Solutions.